use strict;
my $str = '<div class="post-preview">
<div class="post-title">
<div class="post-name">
<a href="{{ post.url }}">{{ post.title }}</a>
</div>
<div class="post-date">
{% include time.html %}
</div>
</div>
<div class="post-snippet">
{% if post.content contains \'<!--break-->\' %}
{{ post.content | split:\'<!--break-->\' | first }}
<div class="post-readmore">
<a href="{{ post.url }}">read more-></a>
</div>
{% endif %}
</div>
{% include post-meta.html %}
</div>';
my $regex = qr/{%\ (if)[\s\S]*?{%\ end\1\ %}|
{%.+?%}|
{{.+?}}/xp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";