re = /{%\ (if)[\s\S]*?{%\ end\1\ %}|
{%.+?%}|
{{.+?}}/x
str = '<div class="post-preview">
<div class="post-title">
<div class="post-name">
<a href="{{ post.url }}">{{ post.title }}</a>
</div>
<div class="post-date">
{% include time.html %}
</div>
</div>
<div class="post-snippet">
{% if post.content contains \'<!--break-->\' %}
{{ post.content | split:\'<!--break-->\' | first }}
<div class="post-readmore">
<a href="{{ post.url }}">read more-></a>
</div>
{% endif %}
</div>
{% include post-meta.html %}
</div>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result