const regex = /[?&]page=[^&\n]+$|([&?])page=[^&\n]+&/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[?&]page=[^&\\n]+$|([&?])page=[^&\\n]+&', 'gm')
const str = `url1?name=John&page=12&mfgid=310
url2?name=John&page=12
url3?page=12&name=John&mfgid=320&my-page=12&foo=bar
url4?page=12
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);