import Foundation
let pattern = #"[?&]page=[^&\n]+$|([&?])page=[^&\n]+&"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
url1?name=John&page=12&mfgid=310
url2?name=John&page=12
url3?page=12&name=John&mfgid=320&my-page=12&foo=bar
url4?page=12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)