$re = '/\[\[([A-Z][\S\s]+?)\]\]/m';
$str = '
[[Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
]]';
$subst = "## $1\r\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;