# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*#.*//gm;t' <<< "1.6 # blah blah blah
# fjsadfklj slkjf yes 3.4
1.8*
1.9 1.10 #blah
#blah
1.11"