import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*#.*";
final String string = "1.6 # blah blah blah\n"
+ "# fjsadfklj slkjf yes 3.4\n"
+ "1.8*\n"
+ "1.9 1.10 #blah\n"
+ "#blah\n"
+ "1.11";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}