const regex = /\s*#.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*#.*', 'gm')
const str = `1.6 # blah blah blah
# fjsadfklj slkjf yes 3.4
1.8*
1.9 1.10 #blah
#blah
1.11`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);