# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*#.*"
test_str = ("1.6 # blah blah blah\n"
"# fjsadfklj slkjf yes 3.4\n"
"1.8*\n"
"1.9 1.10 #blah\n"
"#blah\n"
"1.11")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.