#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:http\:\/\/(?:www\.)?){1}[^\/]*\/([^\/]*)(?#parameter2)(?:\/([^\/]*))?(?#parameter3)(?:\/([^\/]*))?(?#parameter4)(?:\/([^\/]*))?"
Local $sString = "http://localhost/asd/asd/asd/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")