import Foundation
let pattern = #"(^(((\d\d)(([02468][048])|([13579][26]))0229)|(((\d\d)(\d\d)))((((0[1-9])|(1[0-2]))((0[1-9])|(1\d)|(2[0-8])))|((((0[13578])|(1[02]))31)|(((0[1,3-9])|(1[0-2]))(29|30)))))(([01]\d|2[0-3])([0-5]\d)([0-5]\d))$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"19741206131415"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}