$re = '/(\b.+?\b)\1\b/';
$str = 'are blue and then and then more and then and then more very bright';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;