import Foundation
let pattern = #"\[img width=.*?\].*?\[\/img\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<img src="test.jpg" width="" height="" />
<iframe src="somepage.html width="500" height="100"></iframe>
<img src="test2.jpg" width="" height="" />
[url=http://forumexpertwatch.s3.byteark.com/ark_20210602-203927_9e92ba4bc8c48d338943b3827c08fad9_07E145BB-FE0E-4265-806B-A6C6F3E0B4A5.jpeg][img width=499]http://forumexpertwatch.s3.byteark.com/ark_20210602-203927_9e92ba4bc8c48d338943b3827c08fad9_07E145BB-FE0E-4265-806B-A6C6F3E0B4A5.jpeg[/img][/url][br /]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}