import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\- ]+";
final String string = "Link_Info-mc1.7.10-0.3.1.litemod\n"
+ "Mantle-1.7.10-0.3.2.jar\n"
+ "MicdoodleCore-1.7-3.0.11.333.jar\n"
+ "MineTweaker3-1.7.10-3.0.9C.jar\n"
+ "ModTweaker 2-0.8.0.jar\n"
+ "MouseTweaks-2.4.4-mc1.7.10.jar\n"
+ "NEIIntegration-MC1.7.10-1.0.9.jar\n"
+ "NotEnoughItems-1.7.10-1.0.5.110-universal.jar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}