use strict;
my $str = '//site/us/count/Pages/product-a-Thank-you
//site/us/count/Pages/Information-b-Thank-you
//site/us/count/Pages/register-c-Thank-you //site/us/count/Pages/link-d-Thank-you
//site/us/world/Pages/link-e-Thank-you.html //site/us/world/Pages/Register-h-Thank-you.html';
my $regex = qr/^(?!.*\bThank-you$).*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";