import Foundation
let pattern = #"^(?!.*\bThank-you$).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
//site/us/count/Pages/product-a-Thank-you
//site/us/count/Pages/Information-b-Thank-you
//site/us/count/Pages/register-c-Thank-you //site/us/count/Pages/link-d-Thank-you
//site/us/world/Pages/link-e-Thank-you.html //site/us/world/Pages/Register-h-Thank-you.html
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)