using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(deficient)(\s.*?\s)(exhibited)(\s.*?\s)(gmk)";
string input = @"deficient dhte wagdg sdfs exhibited vlskdv gmk
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}