$re = '/\s+style="[^"]+"/m';
$str = '<img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" alt="Johny" title="Johny" style="border: 0;">
<img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" style="border: 0;" alt="Johny" title="Johny">
<img width="32" height="32" src="http://i.stack.imgur.com/xBOdsdp.jpg?s=128&g=5&g&s=3" alt="Johny" title="Johny">';
$subst = "++";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;