import re
regex = re.compile(r"\~\![A-Za-z]+\ start(?:(?:(?:\(|,)\ ?[\w]+)*?\))\:\{((?:(?!\}\:end\n)[\S\s])+)(?:\}\:end)")
test_str = ("~!data start(f1, f2, f3):{\n"
"abc '\\}:end'a\n"
"}:end\n\n"
"~!data start(f1, f2, f3):{\n"
"abc '\\}:end'a\n"
"}:end")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")