// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((([a-z\d](-?[a-z\d]){0,62})\.)*(([a-z\d](-?[a-z\d]){0,62})\.)([a-z](-?[a-z\d]){1,62})|((\d{1,3}\.){3}\d{1,3}))$").unwrap();
let string = "// Valid
a-a.domain.com
1a.domain.com
a1.domain.com
a.domain.com
domain.com
10.10.10.11
// Invalid
-a.domain.com
a-.domain.com
// Valid
cname.do-main.com
cname.1domain.com
cname.domain1.com
// Invalid
cname.-domain.com
cname.domain-.com
// Valid
cname.domain.tld
cname.domain.co
cname.domain.tld1
cname.domain.tld-1
// Invalid
cname.domain.1tld
cname.domain.tld-
cname.domain.-tld";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}