#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[([\d]{1,2}-[\w]{3,9}-[\d]{4}\s+[\d]{2}:[\d]{2}:[\d]{2}\s+[A-Z]{3,4})\]\s((?s).+?)(?=(?:^\[.+\])|\Z)"
Local $sString = "[27-May-2021 05:59:39 UTC] Inpsyde\Idealo\WooCommerce\IdealoException: Plugin "woocommerce" must be installed and active in C:\Users\xedin\Local Sites\idealo\app\public\wp-content\plugins\idealo-for-woocommerce\src\Application.php:172" & @CRLF & _
"[27-May-2021 05:59:39 UTC] PHP Fatal error: Uncaught Error: Class 'ActionScheduler_Lock' not found in C:\Users\xedin\Local Sites\idealo\app\public\wp-content\plugins\idealo-for-woocommerce\vendor\woocommerce\action-scheduler\classes\abstracts\ActionScheduler.php:29" & @CRLF & _
"Stack trace:" & @CRLF & _
"#0 C:\Users\xedin\Local Sites\idealo\app\public\wp-content\plugins\idealo-for-woocommerce\vendor\woocommerce\action-scheduler\classes\ActionScheduler_QueueRunner.php(103): ActionScheduler::lock()" & @CRLF & _
"#1 C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\class-wp-hook.php(292): ActionScheduler_QueueRunner->maybe_dispatch_async_request('')" & @CRLF & _
"#2 C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\class-wp-hook.php(316): WP_Hook->apply_filters(NULL, Array)" & @CRLF & _
"#3 C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\plugin.php(484): WP_Hook->do_action(Array)" & @CRLF & _
"#4 C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\load.php(1072): do_action('shutdown')" & @CRLF & _
"#5 [internal function]: shutdown_action_hook()" & @CRLF & _
"#6 {main}" & @CRLF & _
" thrown in C:\Users\xedin\Local Sites\idealo\app\public\wp-content\plugins\idealo-for-woocommerce\vendor\woocommerce\action-scheduler\classes\abstracts\ActionScheduler.php on line 29" & @CRLF & _
"[27-May-2021 05:59:39 UTC] PHP Stack trace:" & @CRLF & _
"[27-May-2021 05:59:39 UTC] PHP 1. {main}() C:\Users\xedin\Local Sites\idealo\app\public\wp-admin\admin-ajax.php:0" & @CRLF & _
"[27-May-2021 05:59:39 UTC] PHP 2. do_action() C:\Users\xedin\Local Sites\idealo\app\public\wp-admin\admin-ajax.php:187" & @CRLF & _
"[27-May-2021 05:59:39 UTC] PHP 3. WP_Hook->do_action() C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\plugin.php:484" & @CRLF & _
"[27-May-2021 05:59:39 UTC] PHP 4. WP_Hook->apply_filters() C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\class-wp-hook.php:316" & @CRLF & _
"[27-May-2021 05:59:39 UTC] PHP 5. wp_ajax_delete_plugin() C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\class-wp-hook.php:292" & @CRLF & _
"[27-May-2021 05:59:39 UTC] PHP 6. wp_send_json_success() C:\Users\xedin\Local Sites\idealo\app\public\wp-admin\includes\ajax-actions.php:4591" & @CRLF & _
"[27-May-2021 05:59:39 UTC] PHP 7. wp_send_json() C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\functions.php:4151" & @CRLF & _
"[27-May-2021 05:59:39 UTC] PHP 8. wp_die() C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\functions.php:4125" & @CRLF & _
"[27-May-2021 05:59:39 UTC] PHP 9. _ajax_wp_die_handler() C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\functions.php:3421" & @CRLF & _
"[27-May-2021 06:56:26 UTC] PHP Warning: mysqli_real_connect(): (HY000/2002): No connection could be made because the target machine actively refused it." & @CRLF & _
" in C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\wp-db.php on line 1653" & @CRLF & _
"[27-May-2021 06:56:27 UTC] PHP Stack trace:" & @CRLF & _
"[27-May-2021 06:56:27 UTC] PHP 1. {main}() C:\Users\xedin\Local Sites\idealo\app\public\wp-cron.php:0" & @CRLF & _
"[27-May-2021 06:56:27 UTC] PHP 2. require_once() C:\Users\xedin\Local Sites\idealo\app\public\wp-cron.php:44" & @CRLF & _
"[27-May-2021 06:56:27 UTC] PHP 3. require_once() C:\Users\xedin\Local Sites\idealo\app\public\wp-load.php:37" & @CRLF & _
"[27-May-2021 06:56:27 UTC] PHP 4. require_once() C:\Users\xedin\Local Sites\idealo\app\public\wp-config.php:80" & @CRLF & _
"[27-May-2021 06:56:27 UTC] PHP 5. require_wp_db() C:\Users\xedin\Local Sites\idealo\app\public\wp-settings.php:124" & @CRLF & _
"[27-May-2021 06:56:27 UTC] PHP 6. wpdb->__construct() C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\load.php:545" & @CRLF & _
"[27-May-2021 06:56:27 UTC] PHP 7. wpdb->db_connect() C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\wp-db.php:632" & @CRLF & _
"[27-May-2021 06:56:27 UTC] PHP 8. mysqli_real_connect() C:\Users\xedin\Local Sites\idealo\app\public\wp-includes\wp-db.php:1653" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")