re = /attrs={(.+?):\s*(.+?)}/m
str = 'this.mk(attrs={keyCollection.key: 40}))
this.mk(attrs={keyCollection.key: 50, override.key: override.value})
this.mk(attrs={keyCollection.key: 60,
override.key: override.value})'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end