Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^.+?@(?=[a-z0-9-]{0,61}\.[a-z]{2,})
/
gm
Input 1
1
New
user:pass@zxuz.com user@proxy.brew.opendnstest.com/customBlockUserInfo user:@proxy.brew1.opendnstest.com/customBlockUserInfo user:password@proxy.brew2.opendnstest.com/customBlockUserInfo ftp://cnn.example.com&story=breaking_news@foobar.com/top_story.htm