const regex = /(?:youtube(?:-nocookie)?\.com\/(?:[^\/\n\s]+\/\S+\/|(?:v|e(?:mbed)?)\/|\S*?[?&]v=)|youtu\.be\/)([a-zA-Z0-9_-]{11})/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:youtube(?:-nocookie)?\\.com\\\/(?:[^\\\/\\n\\s]+\\\/\\S+\\\/|(?:v|e(?:mbed)?)\\\/|\\S*?[?&]v=)|youtu\\.be\\\/)([a-zA-Z0-9_-]{11})', 'ig')
const str = `<iframe src="https://www.youtube.com/embed/B2j51s2Zte4" width="580" height="418" frameborder="0" allowfullscreen="allowfullscreen"></iframe>
https://www.youtube.com/embed/B2j51s2Zte4
https://www.youtu.be/B2j51s2Zte4
http://youtube.com/v/B2j51s2Zte4
http://youtube.com/?v=B2j51s2Zte4
//youtube.com/watch?v=B2j51s2Zte4
youtu.be/B2j51s2Zte4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}