# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:youtube(?:-nocookie)?\.com\/(?:[^\/\n\s]+\/\S+\/|(?:v|e(?:mbed)?)\/|\S*?[?&]v=)|youtu\.be\/)([a-zA-Z0-9_-]{11})"
test_str = ("<iframe src=\"https://www.youtube.com/embed/B2j51s2Zte4\" width=\"580\" height=\"418\" frameborder=\"0\" allowfullscreen=\"allowfullscreen\"></iframe>\n"
"https://www.youtube.com/embed/B2j51s2Zte4\n"
"https://www.youtu.be/B2j51s2Zte4\n"
"http://youtube.com/v/B2j51s2Zte4\n"
"http://youtube.com/?v=B2j51s2Zte4\n"
"//youtube.com/watch?v=B2j51s2Zte4\n"
"youtu.be/B2j51s2Zte4\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.