import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\p{Sc}\\p{So}\\p{Mn}\\p{P}\\p{Z}À-ÿ]";
final String string = "QWERTYUIOPéAsdfghjklHFIUSAF /*-+!\"£$%&/()?=^*é§°ç_:;[]#@€£█Õ○3═nêj⌂8±£#♫♣èùàò";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}