$re = '/(?<=\\\\").*?(?=\\\\")/';
$str = 'gram:\\"who is $t34he\\"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);