package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:\w+(?:\s|\.))+\s+){2}`)
var str = `The Smithsonian museum is home to a variety of different art displays. According various reports art appreciation is on the rise. Blah blah blah blah.The Smithsonian museum blah blah blah. Blah blah blah blah.`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}