const regex = /[^a-z0-9_\s-]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-z0-9_\\s-]', '')
const str = `Color / Finish`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}