const regex = new RegExp('(?:(?<=^)|(?<=\\D))((00|\\+)?55(\\s|\\.|-)*)?((\\()?0?\\d{2}(?(5)\\)|)(\\s|\\.|-)*)?(9(\\s|\\.|-)*)?\\d{4}(\\s|\\.|-)*\\d{4}(?=\\D|$)', 'gm')
const str = `98993132
9899-3132
9899.3132
9899 3132
7198993132
719899-3132
719899.3132
719899 3132
71 98993132
71 9899-3132
71 9899.3132
71 9899 3132
071 98993132
071 9899-3132
071 9899.3132
071 9899 3132
(71)98993132
(71)9899-3132
(71)9899.3132
(71)9899 3132
(71) 98993132
(71) 9899-3132
(71) 9899.3132
(071) 9899 3132
(071) 98993132
(071) 9899-3132
(071) 9899.3132
(071) 9899 3132
557198993132
55719899-3132
55719899.3132
55719899 3132
5571 98993132
5571 9899-3132
5571 9899.3132
5571 9899 3132
55071 98993132
55071 9899-3132
55071 9899.3132
55071 9899 3132
55(71)98993132
55(71)9899-3132
55(71)9899.3132
55(71)9899 3132
55(71) 98993132
55(71) 9899-3132
55(71) 9899.3132
55(071) 9899 3132
55(071) 98993132
55(071) 9899-3132
55(071) 9899.3132
55(071) 9899 3132
55 7198993132
55 719899-3132
55 719899.3132
55 719899 3132
55 71 98993132
55 71 9899-3132
55 71 9899.3132
55 71 9899 3132
55 071 98993132
55 071 9899-3132
55 071 9899.3132
55 071 9899 3132
55 (71)98993132
55 (71)9899-3132
55 (71)9899.3132
55 (71)9899 3132
55 (71) 98993132
55 (71) 9899-3132
55 (71) 9899.3132
55 (071) 9899 3132
55 (071) 98993132
55 (071) 9899-3132
55 (071) 9899.3132
55 (071) 9899 3132
+557198993132
+55719899-3132
+55719899.3132
+55719899 3132
+5571 98993132
+5571 9899-3132
+5571 9899.3132
+5571 9899 3132
+55071 98993132
+55071 9899-3132
+55071 9899.3132
+55071 9899 3132
+55(71)98993132
+55(71)9899-3132
+55(71)9899.3132
+55(71)9899 3132
+55(71) 98993132
+55(71) 9899-3132
+55(71) 9899.3132
+55(071) 9899 3132
+55(071) 98993132
+55(071) 9899-3132
+55(071) 9899.3132
+55(071) 9899 3132
+55 7198993132
+55 719899-3132
+55 719899.3132
+55 719899 3132
+55 71 98993132
+55 71 9899-3132
+55 71 9899.3132
+55 71 9899 3132
+55 071 98993132
+55 071 9899-3132
+55 071 9899.3132
+55 071 9899 3132
+55 (71)98993132
+55 (71)9899-3132
+55 (71)9899.3132
+55 (71)9899 3132
+55 (71) 98993132
+55 (71) 9899-3132
+55 (71) 9899.3132
+55 (071) 9899 3132
+55 (071) 98993132
+55 (071) 9899-3132
+55 (071) 9899.3132
+55 (071) 9899 3132
998993132
99899-3132
99899.3132
99899 3132
71998993132
7199899-3132
7199899.3132
7199899 3132
71 998993132
71 99899-3132
71 99899.3132
71 99899 3132
071 998993132
071 99899-3132
071 99899.3132
071 99899 3132
(71)998993132
(71)99899-3132
(71)99899.3132
(71)99899 3132
(71) 998993132
(71) 99899-3132
(71) 99899.3132
(071) 99899 3132
(071) 998993132
(071) 99899-3132
(071) 99899.3132
(071) 99899 3132
5571998993132
557199899-3132
557199899.3132
557199899 3132
5571 998993132
5571 99899-3132
5571 99899.3132
5571 99899 3132
55071 998993132
55071 99899-3132
55071 99899.3132
55071 99899 3132
55(71)998993132
55(71)99899-3132
55(71)99899.3132
55(71)99899 3132
55(71) 998993132
55(71) 99899-3132
55(71) 99899.3132
55(071) 99899 3132
55(071) 998993132
55(071) 99899-3132
55(071) 99899.3132
55(071) 99899 3132
55 71998993132
55 7199899-3132
55 7199899.3132
55 7199899 3132
55 71 998993132
55 71 99899-3132
55 71 99899.3132
55 71 99899 3132
55 071 998993132
55 071 99899-3132
55 071 99899.3132
55 071 99899 3132
55 (71)998993132
55 (71)99899-3132
55 (71)99899.3132
55 (71)99899 3132
55 (71) 998993132
55 (71) 99899-3132
55 (71) 99899.3132
55 (071) 99899 3132
55 (071) 998993132
55 (071) 99899-3132
55 (071) 99899.3132
55 (071) 99899 3132
+5571998993132
+557199899-3132
+557199899.3132
+557199899 3132
+5571 998993132
+5571 99899-3132
+5571 99899.3132
+5571 99899 3132
+55071 998993132
+55071 99899-3132
+55071 99899.3132
+55071 99899 3132
+55(71)998993132
+55(71)99899-3132
+55(71)99899.3132
+55(71)99899 3132
+55(71) 998993132
+55(71) 99899-3132
+55(71) 99899.3132
+55(071) 99899 3132
+55(071) 998993132
+55(071) 99899-3132
+55(071) 99899.3132
+55(071) 99899 3132
+55 71998993132
+55 7199899-3132
+55 7199899.3132
+55 7199899 3132
+55 71 998993132
+55 71 99899-3132
+55 71 99899.3132
+55 71 99899 3132
+55 071 998993132
+55 071 99899-3132
+55 071 99899.3132
+55 071 99899 3132
+55 (71)998993132
+55 (71)99899-3132
+55 (71)99899.3132
+55 (71)99899 3132
+55 (71) 998993132
+55 (71) 99899-3132
+55 (71) 99899.3132
+55 (071) 99899 3132
+55 (071) 998993132
+55 (071) 99899-3132
+55 (071) 99899.3132
+55 (071) 99899 3132
9 98993132
9 9899-3132
9 9899.3132
9 9899 3132
719 98993132
719 9899-3132
719 9899.3132
719 9899 3132
71 9 98993132
71 9 9899-3132
71 9 9899.3132
71 9 9899 3132
071 9 98993132
071 9 9899-3132
071 9 9899.3132
071 9 9899 3132
(71)9 98993132
(71)9 9899-3132
(71)9 9899.3132
(71)9 9899 3132
(71) 9 98993132
(71) 9 9899-3132
(71) 9 9899.3132
(071) 9 9899 3132
(071) 9 98993132
(071) 9 9899-3132
(071) 9 9899.3132
(071) 9 9899 3132
55719 98993132
55719 9899-3132
55719 9899.3132
55719 9899 3132
5571 9 98993132
5571 9 9899-3132
5571 9 9899.3132
5571 9 9899 3132
55071 9 98993132
55071 9 9899-3132
55071 9 9899.3132
55071 9 9899 3132
55(71)9 98993132
55(71)9 9899-3132
55(71)9 9899.3132
55(71)9 9899 3132
55(71) 9 98993132
55(71) 9 9899-3132
55(71) 9 9899.3132
55(071) 9 9899 3132
55(071) 9 98993132
55(071) 9 9899-3132
55(071) 9 9899.3132
55(071) 9 9899 3132
55 719 98993132
55 719 9899-3132
55 719 9899.3132
55 719 9899 3132
55 71 9 98993132
55 71 9 9899-3132
55 71 9 9899.3132
55 71 9 9899 3132
55 071 9 98993132
55 071 9 9899-3132
55 071 9 9899.3132
55 071 9 9899 3132
55 (71)9 98993132
55 (71)9 9899-3132
55 (71)9 9899.3132
55 (71)9 9899 3132
55 (71) 9 98993132
55 (71) 9 9899-3132
55 (71) 9 9899.3132
55 (071) 9 9899 3132
55 (071) 9 98993132
55 (071) 9 9899-3132
55 (071) 9 9899.3132
55 (071) 9 9899 3132
+55719 98993132
+55719 9899-3132
+55719 9899.3132
+55719 9899 3132
+5571 9 98993132
+5571 9 9899-3132
+5571 9 9899.3132
+5571 9 9899 3132
+55071 9 98993132
+55071 9 9899-3132
+55071 9 9899.3132
+55071 9 9899 3132
+55(71)9 98993132
+55(71)9 9899-3132
+55(71)9 9899.3132
+55(71)9 9899 3132
+55(71) 9 98993132
+55(71) 9 9899-3132
+55(71) 9 9899.3132
+55(071) 9 9899 3132
+55(071) 9 98993132
+55(071) 9 9899-3132
+55(071) 9 9899.3132
+55(071) 9 9899 3132
+55 719 98993132
+55 719 9899-3132
+55 719 9899.3132
+55 719 9899 3132
+55 71 9 98993132
+55 71 9 9899-3132
+55 71 9 9899.3132
+55 71 9 9899 3132
+55 071 9 98993132
+55 071 9 9899-3132
+55 071 9 9899.3132
+55 071 9 9899 3132
+55 (71)9 98993132
+55 (71)9 9899-3132
+55 (71)9 9899.3132
+55 (71)9 9899 3132
+55 (71) 9 98993132
+55 (71) 9 9899-3132
+55 (71) 9 9899.3132
+55 (071) 9 9899 3132
+55 (071) 9 98993132
+55 (071) 9 9899-3132
+55 (071) 9 9899.3132
+55 (071) 9 9899 3132
====== partial matches =======
55(71 9 7676-3131
55 (71 7676-3131
porque76763131sera
======== no matches ==========
41650-010
123.456.789-00
123456789-00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}