# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*time\s+)(\d{2}:\d{2}\s[ap]m)(.*)/${1}10:10 pm$3/;t' <<< "there is some text and maybe some number or symbols time 12:32 am and there is some text"