$re = '/(?=(\d+)\1+(.*))(\d+?)\3+\2$/';
$str = '1122112211221122';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);