re = /(
(\d+|pi|\\u03C0|\\u03A0|phi|\\u03C6|\\u03A6)
|
(abs|acos|cos|atan|tan|asin|sin|ceil|floor|sqrt|log|ln)\([^)]+\)
)
(
\s*([+\-*\/^]|mod)\s*
(
(\d+|pi|\\u03C0|\\u03A0|phi|\\u03C6|\\u03A6)
|
(abs|acos|cos|atan|tan|asin|sin|ceil|floor|sqrt|log|ln)\([^)]+\)
)
)*
\s*=/x
str = 'test text (1) pi=
test text (1 pi=
test text 1) pi=
test text (2) pi + 10 / 20=
test text (3) test pi ^ 10 / 20=
test text (30) 10 + 5=
test text (500) abs(10 + 5)=
test text (1) pi + 10 / 20=
test text 10*5=
test text pi / phi=
test text 10 mod phi=
test text 50 10 mod phi=
test text pi mod abs(phi)=
apple banana cherry apple 10 apple cherry banana hi 10 99+1=
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end