package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*<parent>\n\s*<groupId>com\.ps\.consul\.releng<\/groupId>\n\s*<artifactId>com\.ps\.consul\.releng<\/artifactId>\n\s*<version>1\.0\.0-SNAPSHOT<\/version>\n\s*<relativePath>\.\.\/com\.ps\.consul\.releng<\/relativePath>\n\s*<\/parent>`)
var str = ` <parent>
<groupId>com.ps.consul.releng</groupId>
<artifactId>com.ps.consul.releng</artifactId>
<version>1.0.0-SNAPSHOT</version>
<relativePath>../com.ps.consul.releng</relativePath>
</parent>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}