import Foundation
let pattern = #"(?<!@)STR"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##" STR @STR #STR"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"FOO"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)