$re = '/ ?[a-z]*oil[a-z]* ?/';
$str = 'foil boil oil toil hello';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;