$re = '/\'/(.+)\n\n/\'/';
$str = '\\\\N97';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);