package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:1){10}|(?:2){10}|(?:3){10}|(?:4){10}|(?:5){10}|(?:6){10}|(?:7){10}|(?:8){10}|(?:9){10|(?:0){10})`)
var str = `2344433`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}