import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{((\\w+)(.\\w+|\\[\\d+\\])+?)\\}\\}";
final String string = "Sayın {{test.ate}} {{Name.Test[1]}} {{Surname.Test[1].Test}} {{a[0].test}} {{a[0].test[0]}} {{a[0].test[0].Yunus[0].Surname}} {{a.a[1][1]}} {{test[1][1][1312312].Test[0].tes.test.tes}} bla bla bla";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}