const regex = /{{((\w+)(.\w+|\[\d+\])+?)}}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{((\\w+)(.\\w+|\\[\\d+\\])+?)}}', 'g')
const str = `Sayın {{test.ate}} {{Name.Test[1]}} {{Surname.Test[1].Test}} {{a[0].test}} {{a[0].test[0]}} {{a[0].test[0].Yunus[0].Surname}} {{a.a[1][1]}} {{test[1][1][1312312].Test[0].tes.test.tes}} bla bla bla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}