import Foundation
let pattern = #"{{((\w+)(.\w+|\[\d+\])+?)}}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Sayın {{test.ate}} {{Name.Test[1]}} {{Surname.Test[1].Test}} {{a[0].test}} {{a[0].test[0]}} {{a[0].test[0].Yunus[0].Surname}} {{a.a[1][1]}} {{test[1][1][1312312].Test[0].tes.test.tes}} bla bla bla"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)