$re = '/\Qfoo/bar\E/m';
$str = 'foo/bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);