using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<b[^<]*?\>([^\s<]+?)\<\/b\>\s*(?!\<br\>)";
string input = @"should NOT match - ok
<b>word</b><br>
should match
<b>word</b> in text
half<b>word</b> ";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}