#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(\-?)((([1-9]([0-9]{0,11}))?)|0)(\.)([0-9]){0,12}$)|(^(\-?)([0-9]){0,12}$)"
Local $sString = "2" & @CRLF & _
"3.87" & @CRLF & _
"636" & @CRLF & _
"4" & @CRLF & _
"3e7" & @CRLF & _
"-190.33" & @CRLF & _
"12345678." & @CRLF & _
"-45" & @CRLF & _
"-0.343" & @CRLF & _
"-3030" & @CRLF & _
"0.999" & @CRLF & _
".25" & @CRLF & _
"0.36" & @CRLF & _
"g" & @CRLF & _
"t555"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")