import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(\\-?)((([1-9]([0-9]{0,11}))?)|0)(\\.)([0-9]){0,12}$)|(^(\\-?)([0-9]){0,12}$)";
final String string = "2\n"
+ "3.87\n"
+ "636\n"
+ "4\n"
+ "3e7\n"
+ "-190.33\n"
+ "12345678.\n"
+ "-45\n"
+ "-0.343\n"
+ "-3030\n"
+ "0.999\n"
+ ".25\n"
+ "0.36\n"
+ "g\n"
+ "t555";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}