#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^h[1,3,5]-f5(?:lb|gtm)01-s\.eset\.com$"
Local $sString = "h1-f5lb01-s.eset.com" & @CRLF & _
"h1-f5gtm01-s.eset.com" & @CRLF & _
"" & @CRLF & _
"h3-f5lb01-s.eset.com" & @CRLF & _
"h3-f5gtm01-s.eset.com" & @CRLF & _
"" & @CRLF & _
"h5-f5lb01-s.eset.com" & @CRLF & _
"h5-f5gtm01-s.eset.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")