const regex = /^h[1,3,5]-f5(?:lb|gtm)01-s\.eset\.com$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^h[1,3,5]-f5(?:lb|gtm)01-s\\.eset\\.com$', 'gmi')
const str = `h1-f5lb01-s.eset.com
h1-f5gtm01-s.eset.com
h3-f5lb01-s.eset.com
h3-f5gtm01-s.eset.com
h5-f5lb01-s.eset.com
h5-f5gtm01-s.eset.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}