$re = '/^((?!501|504)[0-9]*)$/m';
$str = '500
501
502
aaa
503
504
505
bbb
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);