import Foundation
let pattern = #"^(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2})(Z|[\+-]\d{2}:?\d{2})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Should match ISO 8601 datetime for Forecast.io API:
[YYYY]-[MM]-[DD]T[HH]:[MM]:[SS]
with an optional time zone formatted as Z for GMT time or {+,-}[HH]:[MM] (with or without separating colon) for an offset
Should Match:
2008-09-15T15:53:00
2007-03-01T13:00:00Z
2015-10-05T21:46:54-1500
2015-10-05T21:46:54+07:00
Should Not Match:
2015-10-05T21:46:54-02
0
2008
2008-09
2008-09-15
2008-09-15 11:12
2008-09-15 11:12:13
1988-05-26T23:00:00.000Z
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)