// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"'.*?' id='phone\$1'>.*?<").unwrap();
let string = "<div>
<span class='customer' id='phone$0'>Home</span>
<br/>
<span class='customer' id='phone$1'>Business</span>
<br/>
<span class='customer' id='phone$2'>Mobile</span>
</div>";
let substitution = "'customer' id='phone\\$1'>Organization<";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}